Pidgin >= v2.4.3 unter Debian Etch kompilieren

Seit einiger Zeit hat ICQ ein neues Protokoll, welches alte Clients, wie z.B. Pidgin vor Version 2.4.3 vom ICQ-Netzwerk ausschließt. Es erscheint dann beim Anmeldeversuch diese Fehlermeldung:

„The client version you are using is too old.“

Durch eine nette E-Mail eines Besuchers dieses Blogs bin ich darauf aufmerksam gemacht worden, dass das How-To zur Kompilierung und Installation des Instant Messengers „Pidgin“, welches ich am 7. November 2007 in diesem Blog veröffentlicht habe, so ohne weiteres nicht mehr zum Erfolg führt (Update: ich habe den Artikel nun aktualisiert, sodass dieser wieder zum Erfolg führen müsste), wenn man den neuen Pidgin 2.4.3 (oder neuer) aus dem Source Code kompilieren möchte.

Man sollte am besten vor der Kompilierung des neuen Messengers erstmal den alten de-installieren:

cd /home/benutzer/downloads/pidgin-2.4.1
make uninstall

Obiges Beispiel geht davon aus, dass man aktuell Pidgin 2.4.1 drauf hat. Selbstverständlich müsst Ihre die Pfade/Verzeichnisnamen so anpassen, dass der „make“ Befehl aus dem Verzeichnis heraus, in dem ihr den alten Pidgin installiert habt, aufgerufen wird.

Führt man nun im Verzeichnis des neuen Pidgins den „configure“ und den „make“ Befehl aus, könnte es jedoch sein, dass diese Fehlermeldung erscheint:

make: *** No targets specified and no makefile found. Stop.

Oder auf deutsch:

make: *** Keine Targets angegeben und keine „make“-Steuerdatei gefunden. Schluss.

Dies liegt mit großer Wahrscheinlichkeit daran, dass zuvor der Befehl „configure“ nicht richtig durchgelaufen ist, sondern mit einer Fehlermeldung beendet wurde. Nachprüfen lässt sich dies so:

./configure --enable-gnutls=yes
echo $?

Meldet der „echo“ Befehl eine 1, sind Fehler beim „configure“ aufgetreten. Erscheint jedoch eine 0, war alles erfolgreich und der „make“ Befehl müsste zumindest „targets“, nämlich das „makefile“ finden, welches „configure“ erzeugt hat.

Als ich es ausprobierte, bekam ich vom „echo“ eine 1 zurück, d.h. der Lauf von „configure“ war fehlerhaft. Die Fehlermeldung, mit der „configure“ abbrach, war bei mir übrigens diese:

configure: error:
XScreenSaver extension development headers not found.
Use –disable-screensaver if you do not need XScreenSaver extension support, this is required for detecting idle time by mouse and keyboard usage.

Es scheint also so zu sein, dass der neue Pidgin nun auch noch zusätzlich min. 1 weiteres Paket benötigt, welches erst noch installiert werden muss – oder, wie aus der Fehlermeldung zu entnehmen ist, man muss beim „configure“ Befehl noch den Parameter „–disable-screensaver“ anhängen, um diese Unterstützung für Pidgin zu deaktivieren.

Ich habe daraufhin das gewünschte „XScreenSaver extension development“-Paket installiert anstatt für Pidgin diese Unterstützung auszuschalten:

apt-get install libxss-dev

Nun lief „configure“ etwas länger, und dann erhielt ich diese Fehlermeldung:

configure: error:
Startup notification development headers not found.
Use –disable-startup-notification if you do not need it.

Ich habe daraufhin das gewünschte „Startup notification development“-Paket installiert anstatt für Pidgin diese Unterstützung auszuschalten:

apt-get install libstartup-notification0-dev

„configure“ scheiterte danach abermals:

configure: error:
GtkSpell development headers not found.
Use –disable-gtkspell if you do not need it.

Also nun auch noch das „GtkSpell development“-Paket installieren:

apt-get install libgtkspell-dev

„configure“ scheiterte danach abermals:

configure: error:
Meanwhile development headers not found.
Use –disable-meanwhile if you do not need Meanwhile (Sametime) support.

Also nun auch noch das „Meanwhile development“-Paket installieren:

apt-get install libmeanwhile-dev

„configure“ scheiterte danach schon wieder:

configure: error:
avahi development headers not found.
Use –disable-avahi if you do not need avahi (Bonjour) support.

Also nun auch noch die beiden „avahi development“-Pakete installieren:

apt-get install libavahi-client-dev libavahi-glib-dev

„configure“ scheiterte danach schon wieder:

configure: error:
D-Bus development headers not found.
Use –disable-dbus if you do not need D-Bus support.

Also nun auch noch das „D-Bus development“-Paket installieren:

apt-get install libdbus-glib-1-dev

„configure“ scheiterte danach schon wieder:

configure: error:
NetworkManager development headers not found.
Use –disable-nm if you do not need NetworkManager support.

Also nun auch das „NetworkManager development“-Paket installieren:

apt-get install network-manager-dev

„configure“ scheiterte mal wieder:

configure: error:
Perl development headers not found.
Use –disable-perl if you do not need Perl scripting support.

Also nun auch das „Perl development“-Paket installieren:

apt-get install libperl-dev

„configure“ scheiterte mal wieder:

configure: error:
Tcl development headers not found.
Use –disable-tcl if you do not need Tcl scripting support.

Also nun auch das „Tcl development“-Paket installieren:

apt-get install tcl8.4-dev

„configure“ scheiterte mal wieder:

configure: error:
Tk development headers not found.
Use –disable-tk if you do not need Tk scripting support.

Also nun auch das „Tk development“-Paket installieren:

apt-get install tk8.4-dev

„configure“ lief nun sauber durch! Danach habe ich nur noch „make“ und „make install“ ausgeführt.

Fertig!

Die in dieser Anleitung genannten Pakete habe ich nun auch im Artikel „Multiprotokoll Messenger Pidgin unter Debian Etch“ hinzugefügt, sodass auch jene Anleitung funktionieren sollte (und vollständiger als diese hier ist).

Ach übrigens, um von den Lang-Bezeichnungen der Pakete, wie sie bei Fehlermeldungen von „configure“ z.B. aufgetreten sind, auf die eigentlichen Paket-Namen, die „apt-get install“ benötigt, schließen zu können, habe ich auf dieser Seite nachgeschaut („Andere Pakete mit Bezug zu pidgin“ -> die Pakete mit den roten Lämpchen davor, die sog. „build-depends“):
http://packages.debian.org/source/lenny/pidgin

Weitersagen: Diese Icons verlinken auf Bookmark Dienste bei denen Nutzer neue Inhalte finden und mit anderen teilen können.
  • email
  • Google Bookmarks
  • Facebook
  • Twitter
  • del.icio.us
  • Digg
  • LinkedIn
  • Technorati

Flattr this!

6 Kommentare

  1. CC 2 sagt …
    am 3. August 2008 um 13:24 | Permalink

    Vielen Dank für die weitere Anleitung, hat wunderbar geklappt, und dank dem Link zu den Abhängigkeiten habe ich auch die 2 weiteren Pakete gefunden, die bei mir noch gefehlt haben (libgstreamer0.10-dev und libdbus-glib-1-dev).
    Jetzt funktioniert wieder alles, auch mein ICQ-Konto über Pidgin.

    Danke für die Hilfe und Gruß,

    CC 2

  2. ravie sagt …
    am 1. September 2008 um 20:26 | Permalink

    ich möchte euch allen ein eis ausgeben damits hier nicht zu staub trocken wird :)

  3. condor sagt …
    am 1. September 2008 um 22:19 | Permalink

    Jau, Eis!
    Danke für Dein Angebot, ravie ;) Ich werd’s mir merken *g*

    Condor

  4. condor sagt …
    am 18. September 2008 um 23:24 | Permalink

    [Nachtrag zu diesem Artikel:]

    Habe soeben per E-Mail erfahren, dass diese Anleitung auch zur Kompilierung von Pidgin v2.5.1 funktioniert.

    Vielen Dank, Maxe.

    Condor

  5. condor sagt …
    am 14. November 2008 um 0:19 | Permalink

    [Nachtrag zu diesem Artikel:]

    Habe soeben auch Pidgin v2.5.2 kompilieren und installieren können, ohne noch weitere Pakete besorgen zu müssen.

    Condor

  6. duRiel sagt …
    am 10. März 2009 um 13:23 | Permalink

    danke für diese anleitung, hat gut funktioniert. bei mir ging es allerdings mal wieder noch eine stufe härter und ich hatte locker 5 fehlende pakete mehr.